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Part 1: How to Browse a Database

Browsing a database with ChemFinder is intuitive and simple. It requires only two basic steps:

1) opening a Form (which you can regard as a “viewer” for the database)

2) browsing the database

If you are confused or unsure of any of the computer-related terminology used in the following tutorial, you might
want to review the section “Conventions” in the Introduction of the ChemInfo User’s Guide.

OPENING A FORM

First, start the ChemFinder application:

• Using the Windows Explorer (Windows 95/98 and Windows NT 4.0), click the ChemFinder application, which is
named cfw.exe.

ChemFinder  launches and displays an empty form.

To open the Cs_demo database:

1. From the File menu, choose Open, or click the Open tool.

The Open dialog box appears.

2. From the Samples directory, select “Cs_demo.cfw”
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3. Click the Open button

The Cs_demo database opens in ChemFinder:

The file is opened, and the database will be opened with the first record displayed in the form.

Switching Between Open Documents

Each time you open a form, a form window appears. If you have opened more than one form, the form windows are
stacked. The front-most form is the active window where you can actually do work. All open forms are listed in the
Window menu.

There are several ways to make another open form the active window:

• From the Window menu, choose the form.

• Or, click any exposed area of the window you want to be the active window.

• Press Ctrl+Tab to switch among the currently open form windows.

Closing a Form

Now lets close the form you have opened.

To close:

• From the File menu, choose Close.

ChemFinder closes the form.

BROWSING A DATABASE

One way to view a ChemFinder database is simply to browse through the database one record at a time, just as you
would turn the pages in a book. This is a good way to see some of the information available.

• Open the Cs_demo database as in you did in the previous section.

You can now browse through the Cs_demo database using the Record Tools on the Record toolbar. Try it!

First record

Next recordPrevious record

Last recordGo To record

• Click First Record to display the first record in the database.

• Click Previous Record to display the record before the currently shown record.

• Click Next Record to display the record after the currently shown record.

• Click Last Record to display the last record in the database.
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Alternatively, from the Record menu, you can choose the corresponding commands.

You can also go directly to a specific record by using the Go To Record command from the Record menu.

• From the Record menu, choose Go To Record, or click the Go To Record tool.

The Record Number dialog box appears.

NOTE: The current record number is displayed in the Status Bar at the bottom right of the form window.

• In the Record Number dialog, enter the number of the record (within the current list) you want to display, and
click the OK button.

The specified record is displayed.

The Status Bar

As you move among records, counters in the lower right corner of the ChemFinder window change to indicate the
current record, the current list size, and the total number of records in the database. The lower left corner of the same
window displays help for menu items and other information.

When you first open a form, the current list size will equal the total database record count. If you do a search to find a
subset of the entries in the database, then the current list size will change to indicate the number of hits in the search.

Current record Total database size

Current list size

To the left of these counters are three other indicators that show the general status of the database. The first will
display the word “READ” when you are using a read-only database, such as one that is on a CD-ROM. The second
indicator will display the word “ADD” when you are entering a new record. The third will display “QRY” when you
are entering a query.

To hide/show the Status Bar:

• From the View menu, deselect/choose Status Bar.

NOTE: The “ADD” indicator is not applicable to CD-ROM-resident or Read-Only databases.

The Data Table

Sometimes browsing through a data record set is more convenient if the data are presented in tabular format. To
display data in a table:

• From the View menu, choose Data Table.

Selecting Data Table will bring up a list window containing the fields and records in the form.
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To display a particular record in the form:

• Click that record’s entry in the list window.

To resize the column widths in the Data Table:

• Place the cursor on the dividers in the top header. (The cursor should change to the icon shown below.)

• Press and drag to adjust the column width.

To resize the row heights in the Data Table:

• Place the cursor on the dividers in the left header. The cursor will change to the icon shown below.

• Press and drag to adjust the row height.

By default, the fields in the Data Table are displayed in the order in which they were created.

To reorder the columns in the Data Table:

• Click one of the column headers to select the column.

• Drag that header to a new position. The cursor will change to the icon shown below. The new position will be
indicated with a dashed vertical line.

Another convenient method of viewing data is by displaying a form and data table simultaneously in Tile layout.

• If you haven’t done so, choose Data Table from the View menu.
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• Click on the form to activate it.

• From the Window menu, choose Tile.

The form will be displayed on the upper half of the ChemFinder window, and the data table will be on the lower half.
The window that you selected before you chose Tile will be shown in the upper half.

NOTE: If the Data Table window is active (i.e., its title bar is highlighted), then some menu options are not
available. To access these options, first click on the main form window.
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Part 2: How to Search a Database

PERFORMING A TEXT SEARCH

Because databases can be very big, browsing is often an inefficient way to locate specific information. In such cases it
is better to search the database for a record or data item.

Searching a database is like using the index of a book. With an index, you can quickly focus on the few pages you are
interested in. Similarly, when you search a database you will find only those records that have the information you
looked for. Once you have this smaller collection (often called a hit list with each record found termed a hit), you can
browse it much more efficiently than you could the whole database.

This tutorial will show you how to perform a molecular formula and a pure text search, as you learn how to search the
Cs_demo database to find compounds with six carbons and one or two nitrogens. Before you begin:

• Open the Cs_demo database (as in Part 1).

Now you will perform a formula search:

1. From the Search menu, choose Enter Query, or from the Search toolbar, click on the Enter
Query button to clear your form.

The form is cleared to allow you to enter your search terms. Also, the status indicator in the status bar is changed to
remind you that you are in query mode.

2. Click in the Formula data box, and type the query “C6 N1-2” in the formula box.

This entry specifies a molecular formula having six carbon atoms and one or two nitrogen atoms.

3. Click the Find button, or press Enter.

ChemFinder begins its search. The progress of the search is indicated by counters in the status bar at the bottom of
the window. When the search is complete, the number of hits is displayed in the Current List Size window of the
Status Bar, and the form displays the first hit. The list you can browse is limited to the hits found in the search. You
will get 12 hits.

NOTE: If a search gets no hits, an alert appears and the list is automatically reset to the full database

4. From the View menu, choose Data Table to display the hits and verify that the formulas are correct.
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Next, you will perform a pure text search to find all compounds in the Cs_demo database with molecular names
starting with “benz”.

To perform this text search:

1. Click in your form to activate it.

2. Click the Enter Query button to clear your form.

3. Click in the Molecule Name data box, and type the query “benz” in the Name data box.

4. Click the Find button, or press Enter.

Hits will have names which include the starting string “benz”. You will again get 12 hits.

5. From the View menu, choose Data Table to display the hits and verify that the molecular names are correct.

NOTE: Notice that this search gave you “benzene” but not “bromobenzene.” The query you entered above is
an “anchored substring” and thus will only give you any string starting with the indicated substring. For
more information regarding how to specify your text searches, see Chapter 3 of the ChemInfo User’s Guide.

PERFORMING A STRUCTURE SEARCH

To perform a structure-based search of a ChemFinder database, you enter a query by drawing the target structure
using ChemDraw. Structure searches may be used to find compounds which: 1) are identical to the drawn structure,
2) contain the drawn structure as a substructure, or 3) are similar to the drawn structure. In this tutorial you will use
CS ChemDraw from within ChemFinder to search the Cs_demo database to find all molecules which contain the
propanone skeleton as a substructure.

Drawing the Structure with ChemDraw

The first step in performing this substructure search will be to draw a structural query, in this case propanone, using
ChemDraw.

Once again, before you start:

• Open the Cs_demo database.

You will begin as you did for the text search:

• From the Search menu, choose Enter Query, or from the Search toolbar, click on the Enter Query button.

Now that the form has been cleared:

• Right-click in the Structure box, and from the Context menu, choose Edit Structure.

This command will open ChemDraw. You will see the empty ChemDraw main application window and toolbar as
shown on the following page.
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Empty ChemDraw Window

Now you will draw propanone in the ChemDraw window.

1. Click on the Solid Bond tool in the toolbar.

2. Position the pointer (which appears as a cross when a bond tool is selected) anywhere in the empty ChemDraw
window and hold down the mouse button.

3. Drag the mouse diagonally upwards to the right at an angle of about 30 degrees (the Message area at the lower
left corner of the document window shows the angle) and release the mouse button when you have extended
the bond to its fixed length.

2. point 3. drag

NOTE:  Fixed Lengths and Fixed Angles should be checked under the Tools menu, as shown below. If either is
not checked, click it to place a check beside it.
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Next, add a bond:

4. Point to the right atom of the bond.

5. Click the atom to add a bond.

A second bond is automatically deposited at a 120-degree angle between the bonds.

4. point 5. click

Next, add a second bond:

6. Continue pointing to atom C2.

7. Click the atom to add a bond.

6. point 7. click

Next you will change a single bond into a double bond:

8. Point to C2 and hold the mouse button down.

9. Drag from C2 to C4 over the existing single bond. Release the mouse button.

8. point 9. drag

Next you will add labels to the structure. Atom labels can be added in several ways. These will be illustrated in
various steps in the tutorial.

10. Point to atom shown below.

11. Double-click the atom.

10. point 11. double-click
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12. Type  capital “O” in the text box that appears.

To close the text box you can click in an empty area of the window, press Enter, or click to select another tool.

12. type

Now that you have drawn propanone in ChemDraw, the next step is to import the structure into ChemFinder where it
can serve as the basis of a query. To do this:

• Click in the empty structure box in the Cs_demo.cfw window in ChemFinder.

Propanone now appears in the structure box, and you are ready to perform the search.

NOTE: See Structure Searching in Chapter 3 of the ChemInfo User’s Guide for more information on Drawing
in ChemDraw.

Searching for the Structure in ChemFinder

The Search menu offers a number of options. Since you seek all molecules in the Cs_demo database that contain
propanone as a substructure, you should make sure that the Substructure option is selected in the Search menu, and
the Similarity option is deselected. These menu items are toggles; each time you select them, the checkmark is
removed if it was there already, or added if it wasn’t. So before you commence the search:

1. From the Search menu, enable Substructure.

2. From the Search menu, disable Similarity.

NOTE: The Similarity option is discussed in Chapter 3 of the ChemInfo User’s Guide.

The Search menu should now look like this:

Now to search:

• From the Search menu, choose Find or click the Find button.

In the case of a substructure search, the matched portion of each molecule is highlighted in red.

In this search you will get 28 hits (as shown by the Status Bar at the bottom of the form) - structures that contain a
propanone substructure.
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The first hit in the Cs_demo database will be camphor as shown below.

Now, you can browse through these hits.

• Use the Record menu or the Record toolbar to browse the hit list (as you learned in Part 1).

You can also conveniently view the database in tabular format.

• From the View menu, choose Data Table.

The Data Table appears and displays all the records of the current list (in this case, the 28 records that were hit by the
search) in tabular format.

You can use the Data Table to browse your records.

• Click a record in the Data Table to display its record in your form window.

You can also use the Data Table to sort the records by name.

• To sort on the Molname field, double-click on its table header in the Data Table.

After a short pause, the Molname field is sorted alphabetically.
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To restore the original ordering of the records:

• Double-click on the MOL_ID field header.

To edit the column widths of your table headers:

• Position the cursor over a divider of a table header, and drag the cursor to the width you want.

• Close the Data Table by choosing Close from the File menu.

You can return to the full database at any time. To retrieve all the records in your database:

• From the Search menu, choose Retrieve All, or click the Retrieve All button.

NOTE: After a search, you do not need to retrieve all your records before conducting another search; you can
perform another search directly. Each search will cover all records in the database.

PERFORMING A NUMERICAL SEARCH

Numerical searching may use exact values or ranges of values to target desired information. This exercise shows how
to search for compounds whose molecular weights fall within a specified range.

To search in the Cs_demo database for compounds with molecular weights between 90 and 100:

1. With the Cs_demo database form open, click in the form to activate it.

2. Click the Enter Query button to clear the form.

3. Click the Molecular Weight box and type the query “90-100”.

4. Click the Find button.

Hits will have molecular weights between 90 and 100, and you will get 11 hits.

5. Verify that the molecular weights are correct by checking the Data Table.

PERFORMING A COMBINED SEARCH

In some cases, you may wish to combine structure searching with text searching to find a specific class of compounds.
For example, you may want to find all compounds in the database that have a benzene substructure and that have a
molecular weight greater than 400. The procedure for this search is similar to the ones you did previously:

1. With the Cs_demo database form open,  click in your form to activate it, then click the Enter Query button.

2. Right-click on the Structure data box, and from the Context menu, choose Edit Structure.

3. Draw benzene in the “From ChemFinder” window by doing the following.

3a. Click on the Benzene Ring tool.
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3b. Click in the ChemDraw drawing area.

4. Click in the ChemFinder window to bring the structure into the form.

5. Click the Molecular Weight data box and type “>400”.

6. Click the Find button.

You will get 8 hits.

7. Browse your hit list to verify your hits.

Now that you have successfully browsed and searched the Cs_demo database, you are ready to browse and search the
Acros Organics 1999/2000 Chemical catalog.

For more advanced information, please consult the ChemInfo User’s Guide.
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